# RubyGems vulnerable to DNS hijack attack

Advisory record · `GHSA-wp3j-rvfp-624h`

- **Identifiers:** `GHSA-wp3j-rvfp-624h` · `CVE-2015-3900`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-350](https://cwe.mitre.org/data/definitions/350.html)
- **Tags:** [CWE-350](https://agentprime.io/advisories/tag/cwe-350.md)
- **Published:** 14 May 2022
- **Updated:** 30 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2022, 01:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rubygems-update` (RubyGems): affected `>=2.0.0, <2.0.16 || >=2.2.0, <2.2.4 || >=2.4.0, <2.4.7`; fixed in `2.0.16`, `2.2.4`, `2.4.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.089, the 95th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-wp3j-rvfp-624h](https://github.com/advisories/GHSA-wp3j-rvfp-624h)
- [OSV: GHSA-wp3j-rvfp-624h](https://osv.dev/vulnerability/GHSA-wp3j-rvfp-624h)
- <https://nvd.nist.gov/vuln/detail/CVE-2015-3900>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2015-3900.yml>
- <https://puppet.com/security/cve/CVE-2015-3900>
- <https://web.archive.org/web/20170331091241/https://puppet.com/security/cve/CVE-2015-3900>
- <https://web.archive.org/web/20200228055155/http://www.securityfocus.com/bid/75482>
- <https://www.trustwave.com/Resources/Security-Advisories/Advisories/TWSL2015-007/?fid=6356>
- <https://www.trustwave.com/Resources/SpiderLabs-Blog/Attacking-Ruby-Gem-Security-with-CVE-2015-3900>
- <http://blog.rubygems.org/2015/05/14/CVE-2015-3900.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2015-August/163502.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2015-August/163600.html>
- <http://lists.fedoraproject.org/pipermail/package-announce/2015-August/164236.html>
- <http://rhn.redhat.com/errata/RHSA-2015-1657.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wp3j-rvfp-624h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wp3j-rvfp-624h/>. Everything for agents: <https://agentprime.io/llms.txt>.
