# Concrete CMS has a session-hardening bypass and allows password change without reauthorization

Advisory record · `GHSA-wmw3-3fv3-h54w`

- **Identifiers:** `GHSA-wmw3-3fv3-h54w` · `CVE-2026-8327` · `PKSA-5dbv-8tcv-hjg5`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-269](https://cwe.mitre.org/data/definitions/269.html) · [CWE-620](https://cwe.mitre.org/data/definitions/620.html) · [CWE-915](https://cwe.mitre.org/data/definitions/915.html)
- **Tags:** [Privilege escalation](https://agentprime.io/advisories/tag/privilege-escalation.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-620](https://agentprime.io/advisories/tag/cwe-620.md)
- **Published:** 22 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 May 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `concrete5/concrete5` (Packagist): affected `<9.5.1`; fixed in `9.5.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Concrete CMS versions below 9.5.1 (Packagist package concrete5/concrete5) are affected. The user-profile edit controller passes the entire raw POST array to UserInfo::update() without field whitelisting, which lets a registered user change their password without supplying the current password and disable the per-user IP pinning that the session validator uses to detect hijacking. Upgrade to version 9.5.1, which fixes the issue.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (ConcreteCMS)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0018, the 7th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:01 UTC: First seen by agentprime
- 31 Oct 2026, 14:01 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wmw3-3fv3-h54w)

## Sources

- [GitHub Advisory Database: GHSA-wmw3-3fv3-h54w](https://github.com/advisories/GHSA-wmw3-3fv3-h54w)
- [OSV: GHSA-wmw3-3fv3-h54w](https://osv.dev/vulnerability/GHSA-wmw3-3fv3-h54w)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-8327>
- <https://documentation.concretecms.org/9-x/developers/introduction/version-history/951-release-notes>
- <https://github.com/concretecms/concretecms>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wmw3-3fv3-h54w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wmw3-3fv3-h54w/>. Everything for agents: <https://agentprime.io/llms.txt>.
