# Improper Input Validation in nyholm/psr7

Advisory record · `GHSA-wjfc-pgfp-pv9c`

- **Identifiers:** `GHSA-wjfc-pgfp-pv9c` · `PKSA-8ds9-sp96-ghmb`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 21 Apr 2023
- **Updated:** 29 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Apr 2023, 20:27 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `nyholm/psr7` (Packagist): affected `<1.6.1`; fixed in `1.6.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> nyholm/psr7 versions before 1.6.1 do not properly validate header parsing, allowing a newline character to be inserted into header names and values. The source says many servers accept a bare newline pair as the end of the header list, so an attacker who can supply header data could potentially alter how headers are interpreted. Upgrade to nyholm/psr7 1.6.1 or later. No workarounds are listed.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:29 UTC: First seen by agentprime
- 31 Oct 2026, 14:29 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wjfc-pgfp-pv9c)

## Sources

- [GitHub Advisory Database: GHSA-wjfc-pgfp-pv9c](https://github.com/advisories/GHSA-wjfc-pgfp-pv9c)
- [OSV: GHSA-wjfc-pgfp-pv9c](https://osv.dev/vulnerability/GHSA-wjfc-pgfp-pv9c)
- <https://github.com/Nyholm/psr7/security/advisories/GHSA-wjfc-pgfp-pv9c>
- <https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96>
- <https://github.com/guzzle/psr7/security/advisories/GHSA-wxmh-65f7-jcvw>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-29197>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/nyholm/psr7/2023-04-17.yaml>
- <https://github.com/Nyholm/psr7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wjfc-pgfp-pv9c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wjfc-pgfp-pv9c/>. Everything for agents: <https://agentprime.io/llms.txt>.
