# Exposure of information in Action Pack

Advisory record · `GHSA-wh98-p28r-vrc9`

- **Identifiers:** `GHSA-wh98-p28r-vrc9` · `CVE-2022-23633`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 11 Feb 2022
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Feb 2022, 20:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `actionpack` (RubyGems): affected `>=5.0.0.0, <5.2.6.2 || >=6.0.0.0, <6.0.4.6 || >=6.1.0.0, <6.1.4.6 || >=7.0.0.0, <7.0.2.2`; fixed in `5.2.6.2`, `6.0.4.6`, `6.1.4.6`, `7.0.2.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.022, the 82nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 11 Feb 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-wh98-p28r-vrc9](https://github.com/advisories/GHSA-wh98-p28r-vrc9)
- [OSV: GHSA-wh98-p28r-vrc9](https://osv.dev/vulnerability/GHSA-wh98-p28r-vrc9)
- <https://github.com/rails/rails/security/advisories/GHSA-wh98-p28r-vrc9>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-23633>
- <https://github.com/rails/rails/commit/f9a2ad03943d5c2ba54e1d45f155442b519c75da>
- <https://discuss.rubyonrails.org/t/cve-2022-23633-possible-exposure-of-information-vulnerability-in-action-pack/80016>
- <https://github.com/rails/rails>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2022-23633.yml>
- <https://groups.google.com/g/ruby-security-ann/c/FkTM-_7zSNA/m/K2RiMJBlBAAJ>
- <https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html>
- <https://rubyonrails.org/2022/2/11/Rails-7-0-2-2-6-1-4-6-6-0-4-6-and-5-2-6-2-have-been-released>
- <https://security.netapp.com/advisory/ntap-20240119-0013>
- <https://www.debian.org/security/2023/dsa-5372>
- <http://www.openwall.com/lists/oss-security/2022/02/11/5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wh98-p28r-vrc9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wh98-p28r-vrc9/>. Everything for agents: <https://agentprime.io/llms.txt>.
