# Netty: HAProxy V1 Protocol CRLF Injection via AF_UNIX Address

Advisory record · `GHSA-wh89-7897-x99h`

- **Identifiers:** `GHSA-wh89-7897-x99h` · `CVE-2026-59919`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-93](https://cwe.mitre.org/data/definitions/93.html)
- **Tags:** [Other injection](https://agentprime.io/advisories/tag/injection.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 21:51 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-haproxy` (Maven): affected `>=4.2.0.Final, <4.2.16.Final || <4.1.136.Final`; fixed in `4.2.16.Final`, `4.1.136.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's io.netty:netty-codec-haproxy package is vulnerable in versions 4.2.0.Final up to 4.2.16.Final and in versions before 4.1.136.Final. The HAProxy V1 encoder does not check AF_UNIX addresses for CRLF characters, so an application that builds those addresses from untrusted input can let an attacker inject a second PROXY header line, which can spoof the client IP to a backend. Upgrade to 4.2.16.Final or 4.1.136.Final, or later. The source gives few details on the exact preconditions beyond the affected use cases.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0016, the 5th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wh89-7897-x99h)

## Sources

- [GitHub Advisory Database: GHSA-wh89-7897-x99h](https://github.com/advisories/GHSA-wh89-7897-x99h)
- [OSV: GHSA-wh89-7897-x99h](https://osv.dev/vulnerability/GHSA-wh89-7897-x99h)
- <https://github.com/netty/netty/security/advisories/GHSA-wh89-7897-x99h>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.1.136.Final>
- <https://github.com/netty/netty/releases/tag/netty-4.2.16.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wh89-7897-x99h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wh89-7897-x99h/>. Everything for agents: <https://agentprime.io/llms.txt>.
