# GeoServer has a Server-Side Template Injection (SSTI) vulnerability in processing FreeMarker templates

Advisory record · `GHSA-wf6j-gr27-g7ch`

- **Identifiers:** `GHSA-wf6j-gr27-g7ch` · `CVE-2024-45747`
- **State:** Confirmed
- **Severity:** CVSS 7.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-749](https://cwe.mitre.org/data/definitions/749.html)
- **Tags:** [CWE-749](https://agentprime.io/advisories/tag/cwe-749.md)
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Aug 2026, 19:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.geoserver:gs-main` (Maven): affected `<2.27.0`; fixed in `2.27.0`
- `org.geoserver:gs-wms` (Maven): affected `<2.27.0`; fixed in `2.27.0`
- `org.geoserver.web:gs-web-app` (Maven): affected `<2.27.0`; fixed in `2.27.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GeoServer versions before 2.27.0 (org.geoserver:gs-main, org.geoserver:gs-wms and org.geoserver.web:gs-web-app) are vulnerable to server-side template injection through FreeMarker templates. An authenticated administrator who uploads a crafted template can run OS commands and read or write arbitrary files on the server. Upgrade to GeoServer 2.27.0 or later, which adds application properties that restrict the objects templates can access.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wf6j-gr27-g7ch)

## Sources

- [GitHub Advisory Database: GHSA-wf6j-gr27-g7ch](https://github.com/advisories/GHSA-wf6j-gr27-g7ch)
- [OSV: GHSA-wf6j-gr27-g7ch](https://osv.dev/vulnerability/GHSA-wf6j-gr27-g7ch)
- <https://github.com/geoserver/geoserver/security/advisories/GHSA-wf6j-gr27-g7ch>
- <https://github.com/geoserver/geoserver/pull/8164>
- <https://docs.geoserver.org/latest/en/user/tutorials/GetFeatureInfo/html/#accessing-instance-methods>
- <https://github.com/geoserver/geoserver>
- <https://osgeo-org.atlassian.net/browse/GEOS-11645>
- <https://osgeo-org.atlassian.net/browse/GEOS-11777>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wf6j-gr27-g7ch>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wf6j-gr27-g7ch/>. Everything for agents: <https://agentprime.io/llms.txt>.
