# Hydra legacy target blacklist permits unsafe PyYAML loading

Advisory record · `GHSA-wf6j-7hvr-gr93`

- **Identifiers:** `GHSA-wf6j-7hvr-gr93`
- **State:** Confirmed
- **Severity:** CVSS 7.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-184](https://cwe.mitre.org/data/definitions/184.html)
- **Tags:** [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 17:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `hydra-core` (PyPI): affected `>=1.3.6, <1.3.8 || >=1.4.0.dev9, <1.4.0rc3`; fixed in `1.3.8`, `1.4.0rc3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Hydra (hydra-core on PyPI) versions 1.3.6 through 1.3.7 and the 1.4 prereleases from 1.4.0.dev9 before 1.4.0rc3 have a legacy target blacklist that leaves PyYAML's unsafe loading functions unblocked. An attacker who controls the targets and arguments an application passes to instantiate() can run Python code in the application's process, for example through a YAML config stream, such as one bundled in a third-party model. Upgrade to hydra-core 1.3.8 or 1.4.0rc3; the source also advises not passing untrusted configuration to instantiate() or call().

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.8 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wf6j-7hvr-gr93)

## Sources

- [GitHub Advisory Database: GHSA-wf6j-7hvr-gr93](https://github.com/advisories/GHSA-wf6j-7hvr-gr93)
- [OSV: GHSA-wf6j-7hvr-gr93](https://osv.dev/vulnerability/GHSA-wf6j-7hvr-gr93)
- <https://github.com/hydra-ecosystem/hydra/security/advisories/GHSA-757g-8w3h-hp29>
- <https://github.com/hydra-ecosystem/hydra/commit/9a7a9a287d565311183da3392bee4345a7fab6d7>
- <https://github.com/hydra-ecosystem/hydra/commit/de5554320c17cd2d974492c03d0b1456adb4a8ef>
- <https://github.com/hydra-ecosystem/hydra>
- <https://github.com/hydra-ecosystem/hydra/releases/tag/v1.3.8>
- <https://github.com/hydra-ecosystem/hydra/releases/tag/v1.4.0rc3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wf6j-7hvr-gr93>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wf6j-7hvr-gr93/>. Everything for agents: <https://agentprime.io/llms.txt>.
