# Netty: TOCTOU in OcspServerCertificateValidator

Advisory record · `GHSA-wc96-39fc-566f`

- **Identifiers:** `GHSA-wc96-39fc-566f` · `CVE-2026-56822`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-367](https://cwe.mitre.org/data/definitions/367.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 21:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-handler-ssl-ocsp` (Maven): affected `>=4.2.0.Final, <4.2.16.Final || <4.1.136.Final`; fixed in `4.2.16.Final`, `4.1.136.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-wc96-39fc-566f: Netty's OcspServerCertificateValidator in io.netty:netty-handler-ssl-ocsp, versions 4.2.0.Final up to but not including 4.2.16.Final, and versions up to but not including 4.1.136.Final, forwards the TLS handshake completion event before the asynchronous OCSP revocation check finishes. A malicious server presenting a revoked certificate can receive application data from a client, or send data to it, during the window before the check closes the channel. Upgrade to 4.2.16.Final or 4.1.136.Final.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0017, the 6th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wc96-39fc-566f)

## Sources

- [GitHub Advisory Database: GHSA-wc96-39fc-566f](https://github.com/advisories/GHSA-wc96-39fc-566f)
- [OSV: GHSA-wc96-39fc-566f](https://osv.dev/vulnerability/GHSA-wc96-39fc-566f)
- <https://github.com/netty/netty/security/advisories/GHSA-wc96-39fc-566f>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.1.136.Final>
- <https://github.com/netty/netty/releases/tag/netty-4.2.16.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wc96-39fc-566f>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wc96-39fc-566f/>. Everything for agents: <https://agentprime.io/llms.txt>.
