# Mattermost Confluence Plugin has Improper Check for Unusual or Exceptional Conditions in github.com/mattermost/mattermost-plugin-confluence

Advisory record · `GHSA-w92j-c6gr-hj8r`

- **Identifiers:** `GHSA-w92j-c6gr-hj8r` · `CVE-2025-53514` · `GO-2025-3871`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-754](https://cwe.mitre.org/data/definitions/754.html)
- **Tags:** [CWE-754](https://agentprime.io/advisories/tag/cwe-754.md)
- **Published:** 18 Aug 2025
- **Updated:** 3 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Aug 2025, 13:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/mattermost/mattermost-plugin-confluence` (Go): affected `<1.5.0`; fixed in `1.5.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (Mattermost)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 24th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Aug 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-w92j-c6gr-hj8r](https://github.com/advisories/GHSA-w92j-c6gr-hj8r)
- [OSV: GHSA-w92j-c6gr-hj8r](https://osv.dev/vulnerability/GHSA-w92j-c6gr-hj8r)
- <https://github.com/advisories/GHSA-w92j-c6gr-hj8r>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-53514>
- <https://mattermost.com/security-updates>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w92j-c6gr-hj8r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w92j-c6gr-hj8r/>. Everything for agents: <https://agentprime.io/llms.txt>.
