# PEAR HTTP_Request2 vulnerable to Cross-site Scripting

Advisory record · `GHSA-w7gh-f2fm-9q8r`

- **Identifiers:** `GHSA-w7gh-f2fm-9q8r` · `CVE-2025-43717` · `PKSA-jrt3-xndd-g4sz`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-531](https://cwe.mitre.org/data/definitions/531.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-531](https://agentprime.io/advisories/tag/cwe-531.md)
- **Published:** 17 Apr 2025
- **Updated:** 17 Apr 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Apr 2025, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pear/http_request2` (Packagist): affected `<2.7.0`; fixed in `2.7.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> PEAR HTTP_Request2 versions before 2.7.0 are vulnerable to cross-site scripting. Several test scripts in its tests directory, including tests/\_network/getparameters.php and tests/\_network/postparameters.php, echo back any GET or POST parameters without escaping. Upgrade to version 2.7.0 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 26th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:27 UTC: First seen by agentprime
- 31 Oct 2026, 14:27 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w7gh-f2fm-9q8r)

## Sources

- [GitHub Advisory Database: GHSA-w7gh-f2fm-9q8r](https://github.com/advisories/GHSA-w7gh-f2fm-9q8r)
- [OSV: GHSA-w7gh-f2fm-9q8r](https://osv.dev/vulnerability/GHSA-w7gh-f2fm-9q8r)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-43717>
- <https://github.com/pear/HTTP_Request2/commit/07925aa77e441dba0ff0fa973a09802729cb838f>
- <https://github.com/pear/HTTP_Request2/commit/265e05f9e08a28a38a57219516a8e4e2dfdbb147>
- <https://github.com/pear/HTTP_Request2>
- <https://github.com/pear/HTTP_Request2/blob/b1c61b71128045734d757c4d3d436457ace80ea7/package.xml#L24>
- <https://github.com/pear/HTTP_Request2/compare/v2.6.0...v2.7.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w7gh-f2fm-9q8r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w7gh-f2fm-9q8r/>. Everything for agents: <https://agentprime.io/llms.txt>.
