# openc3-api Vulnerable to Unauthenticated Remote Code Execution

Advisory record · `GHSA-w757-4qv9-mghp`

- **Identifiers:** `GHSA-w757-4qv9-mghp` · `CVE-2025-68271`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-95](https://cwe.mitre.org/data/definitions/95.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md)
- **Published:** 13 Jan 2026
- **Updated:** 3 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Jan 2026, 19:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `openc3` (RubyGems): affected `>=5.0.6, <6.10.2`; fixed in `6.10.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 13 Jan 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-w757-4qv9-mghp](https://github.com/advisories/GHSA-w757-4qv9-mghp)
- [OSV: GHSA-w757-4qv9-mghp](https://osv.dev/vulnerability/GHSA-w757-4qv9-mghp)
- <https://github.com/OpenC3/cosmos/security/advisories/GHSA-w757-4qv9-mghp>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-68271>
- <https://github.com/OpenC3/cosmos/commit/01e9fbc5e66e9a2500b71a75a44775dd1fc2d1de>
- <https://github.com/OpenC3/cosmos>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/openc3/CVE-2025-68271.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w757-4qv9-mghp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w757-4qv9-mghp/>. Everything for agents: <https://agentprime.io/llms.txt>.
