# c3p0 can, in combination with other libraries, compose to a "sink" for deserialization gadgets

Advisory record · `GHSA-w6w4-rjh9-9r58`

- **Identifiers:** `GHSA-w6w4-rjh9-9r58` · `CVE-2026-55223`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-915](https://cwe.mitre.org/data/definitions/915.html)
- **Tags:** [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 23 Jul 2026
- **Updated:** 23 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Jul 2026, 19:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.mchange:c3p0` (Maven): affected `<0.14.0`; fixed in `0.14.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> c3p0 versions below 0.14.0 are affected. An attacker who can get a serialized object into a location the application deserializes can use a crafted c3p0 DataSource, combined with a vulnerable JDBC driver and a bean-property-reading gadget on the classpath, to trigger attacks during deserialization. Upgrade to c3p0 0.14.0 or later, which excludes the risky bean properties; on Java 16 or later, the stronger reflection restrictions may block some variants of this attack.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w6w4-rjh9-9r58)

## Sources

- [GitHub Advisory Database: GHSA-w6w4-rjh9-9r58](https://github.com/advisories/GHSA-w6w4-rjh9-9r58)
- [OSV: GHSA-w6w4-rjh9-9r58](https://osv.dev/vulnerability/GHSA-w6w4-rjh9-9r58)
- <https://github.com/swaldman/c3p0/security/advisories/GHSA-w6w4-rjh9-9r58>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-55223>
- <https://github.com/swaldman/c3p0/commit/7b022c4b6694dabc6204254dc917af9c38f2cb27>
- <https://github.com/swaldman/c3p0>
- <https://github.com/swaldman/c3p0/releases/tag/v0.14.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w6w4-rjh9-9r58>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w6w4-rjh9-9r58/>. Everything for agents: <https://agentprime.io/llms.txt>.
