# LocalAI Cross-Site Scripting (XSS) vulnerability in its search functionality

Advisory record · `GHSA-w6hh-w36c-vxmw`

- **Identifiers:** `GHSA-w6hh-w36c-vxmw` · `CVE-2024-9900` · `GO-2025-3542`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-115](https://cwe.mitre.org/data/definitions/115.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-115](https://agentprime.io/advisories/tag/cwe-115.md)
- **Published:** 20 Mar 2025
- **Updated:** 25 Mar 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Mar 2025, 12:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/mudler/LocalAI` (Go): affected `<2.22.0`; fixed in `2.22.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Mar 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-w6hh-w36c-vxmw](https://github.com/advisories/GHSA-w6hh-w36c-vxmw)
- [OSV: GHSA-w6hh-w36c-vxmw](https://osv.dev/vulnerability/GHSA-w6hh-w36c-vxmw)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-9900>
- <https://github.com/mudler/localai/commit/a1634b219a4e52813e70ff07e6376a01449c4515>
- <https://github.com/mudler/LocalAI>
- <https://huntr.com/bounties/b39cd230-db66-471b-89b9-24afaa078e68>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w6hh-w36c-vxmw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w6hh-w36c-vxmw/>. Everything for agents: <https://agentprime.io/llms.txt>.
