# RabbitMQ vulnerable to Denial of Service by publishing large messages over the HTTP API

Advisory record · `GHSA-w6cq-9cf4-gqpg`

- **Identifiers:** `GHSA-w6cq-9cf4-gqpg` · `BIT-rabbitmq-2023-46118` · `CVE-2023-46118`
- **State:** Confirmed
- **Severity:** CVSS 4.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 30 Jun 2026
- **Updated:** 30 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Jun 2026, 16:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `rabbit_common` (Hex): affected `>=3.12.0, <3.12.7 || >=3.11.0, <3.11.24`; fixed in `3.12.7`, `3.11.24`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 70th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:25 UTC: First seen by agentprime
- 31 Oct 2026, 15:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w6cq-9cf4-gqpg)

## Sources

- [GitHub Advisory Database: GHSA-w6cq-9cf4-gqpg](https://github.com/advisories/GHSA-w6cq-9cf4-gqpg)
- [OSV: GHSA-w6cq-9cf4-gqpg](https://osv.dev/vulnerability/GHSA-w6cq-9cf4-gqpg)
- <https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-46118>
- <https://github.com/rabbitmq/rabbitmq-server>
- <https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html>
- <https://www.debian.org/security/2023/dsa-5571>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w6cq-9cf4-gqpg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w6cq-9cf4-gqpg/>. Everything for agents: <https://agentprime.io/llms.txt>.
