# Froxlor has Local File Inclusion via path traversal in API \`def_language\` parameter leads to Remote Code Execution

Advisory record · `GHSA-w59f-67xm-rxx7`

- **Identifiers:** `GHSA-w59f-67xm-rxx7` · `CVE-2026-41228` · `PKSA-t427-p3m6-gf3c`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-98](https://cwe.mitre.org/data/definitions/98.html)
- **Tags:** [File inclusion](https://agentprime.io/advisories/tag/file-inclusion.md)
- **Published:** 16 Apr 2026
- **Updated:** 5 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Apr 2026, 01:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `froxlor/froxlor` (Packagist): affected `<2.3.6`; fixed in `2.3.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Froxlor versions before 2.3.6 are vulnerable. An authenticated customer can set the def_language parameter through the API to a path traversal value, causing the panel to include and execute an attacker-controlled PHP file, which can lead to arbitrary code execution as the web server user. Upgrade to Froxlor 2.3.6 or later. The source gives no workaround.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w59f-67xm-rxx7)

## Sources

- [GitHub Advisory Database: GHSA-w59f-67xm-rxx7](https://github.com/advisories/GHSA-w59f-67xm-rxx7)
- [OSV: GHSA-w59f-67xm-rxx7](https://osv.dev/vulnerability/GHSA-w59f-67xm-rxx7)
- <https://github.com/froxlor/froxlor/security/advisories/GHSA-w59f-67xm-rxx7>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-41228>
- <https://github.com/froxlor/froxlor/commit/bc5e6dbaa90e6f3573129da640595e8c770e1d0c>
- <https://github.com/froxlor/froxlor>
- <https://github.com/froxlor/froxlor/releases/tag/2.3.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w59f-67xm-rxx7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w59f-67xm-rxx7/>. Everything for agents: <https://agentprime.io/llms.txt>.
