# Next Server Actions Source Code Exposure

Advisory record · `GHSA-w37m-7fhw-fmv9`

- **Identifiers:** `GHSA-w37m-7fhw-fmv9`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-497](https://cwe.mitre.org/data/definitions/497.html) · [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 11 Dec 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Dec 2025, 22:49 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=15.0.0-canary.0, <15.0.6 || >=15.1.1-canary.0, <15.1.10 || >=15.2.0-canary.0, <15.2.7 || >=15.3.0-canary.0, <15.3.7 || >=15.4.0-canary.0, <15.4.9 || >=15.5.1-canary.0, <15.5.8 || >=15.6.0-canary.0, <15.6.0-canary.59 || >=16.0.0-beta.0, <16.0.9 || >=16.1.0-canary.0, <16.1.0-canary.17`; fixed in `15.0.6`, `15.1.10`, `15.2.7`, `15.3.7`, `15.4.9`, `15.5.8`, `15.6.0-canary.59`, `16.0.9`, `16.1.0-canary.17`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 11 Dec 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-w37m-7fhw-fmv9](https://github.com/advisories/GHSA-w37m-7fhw-fmv9)
- [OSV: GHSA-w37m-7fhw-fmv9](https://osv.dev/vulnerability/GHSA-w37m-7fhw-fmv9)
- <https://github.com/vercel/next.js/security/advisories/GHSA-w37m-7fhw-fmv9>
- <https://github.com/vercel/next.js>
- <https://nextjs.org/blog/security-update-2025-12-11>
- <https://www.cve.org/CVERecord?id=CVE-2025-55183>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w37m-7fhw-fmv9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w37m-7fhw-fmv9/>. Everything for agents: <https://agentprime.io/llms.txt>.
