# Okio Signed to Unsigned Conversion Error vulnerability

Advisory record · `GHSA-w33c-445m-f8w7`

- **Identifiers:** `GHSA-w33c-445m-f8w7` · `CVE-2023-3635`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-195](https://cwe.mitre.org/data/definitions/195.html) · [CWE-681](https://cwe.mitre.org/data/definitions/681.html)
- **Tags:** [CWE-195](https://agentprime.io/advisories/tag/cwe-195.md) · [CWE-681](https://agentprime.io/advisories/tag/cwe-681.md)
- **Published:** 12 Jul 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Jul 2023, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.squareup.okio:okio` (Maven): affected `>=2.0.0-RC1, <3.4.0 || <1.17.6`; fixed in `3.4.0`, `1.17.6`
- `com.squareup.okio:okio-jvm` (Maven): affected `>=2.0.0-RC1, <3.4.0`; fixed in `3.4.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Okio (com.squareup.okio:okio) versions from 2.0.0-RC1 before 3.4.0, and versions before 1.17.6, are affected, as are okio-jvm versions from 2.0.0-RC1 before 3.4.0. An attacker who can supply a crafted GZIP archive that the application reads through GzipSource can cause a denial of service in the Okio client. Upgrade okio to 3.4.0 or 1.17.6, and okio-jvm to 3.4.0.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (JFROG)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 69th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w33c-445m-f8w7)

## Sources

- [GitHub Advisory Database: GHSA-w33c-445m-f8w7](https://github.com/advisories/GHSA-w33c-445m-f8w7)
- [OSV: GHSA-w33c-445m-f8w7](https://osv.dev/vulnerability/GHSA-w33c-445m-f8w7)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-3635>
- <https://github.com/square/okio/pull/1280>
- <https://github.com/square/okio/pull/1334>
- <https://github.com/square/okio/commit/81bce1a30af244550b0324597720e4799281da7b>
- <https://github.com/square/okio/commit/b4fa875dc24950680c386e4b1c593660ce4f7839>
- <https://github.com/square/okio>
- <https://github.com/square/okio/blob/master/CHANGELOG.md#version-1176>
- <https://research.jfrog.com/vulnerabilities/okio-gzip-source-unhandled-exception-dos-xray-523195>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w33c-445m-f8w7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w33c-445m-f8w7/>. Everything for agents: <https://agentprime.io/llms.txt>.
