# Wagtail has permission check bypass when editing a model with per-field restrictions through \`wagtail.contrib.settings\` or \`ModelViewSet\`

Advisory record · `GHSA-w2v8-php4-p8hc`

- **Identifiers:** `GHSA-w2v8-php4-p8hc` · `CVE-2024-32882` · `PYSEC-2026-2031`
- **State:** Confirmed
- **Severity:** CVSS 2.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html) · [CWE-281](https://cwe.mitre.org/data/definitions/281.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md) · [CWE-281](https://agentprime.io/advisories/tag/cwe-281.md)
- **Published:** 1 May 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 May 2024, 16:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `>=6.0.0, <6.0.3`; fixed in `6.0.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Wagtail versions 6.0.0 up to but not including 6.0.3 are vulnerable when a model exposed through wagtail.contrib.settings or ModelViewSet has a FieldPanel permission restriction on one or more fields. A user who has edit permission on the model but not on the restricted field can craft a POST request to change that field's value; ordinary site visitors and users without model edit access cannot exploit it. Upgrade to Wagtail 6.0.3 or 6.1. For ModelViewSet, registering the model as a snippet is a workaround; no workaround is available for wagtail.contrib.settings.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w2v8-php4-p8hc)

## Sources

- [GitHub Advisory Database: GHSA-w2v8-php4-p8hc](https://github.com/advisories/GHSA-w2v8-php4-p8hc)
- [OSV: GHSA-w2v8-php4-p8hc](https://osv.dev/vulnerability/GHSA-w2v8-php4-p8hc)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-w2v8-php4-p8hc>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-32882>
- <https://github.com/wagtail/wagtail/commit/ab2a5d82b4ee3c909d2456704388ccf90e367c9b>
- <https://github.com/wagtail/wagtail/commit/fa0d4829f9c81eefb37cc058e2fa1b6a918741da>
- <https://docs.wagtail.org/en/stable/extending/generic_views.html#modelviewset>
- <https://docs.wagtail.org/en/stable/reference/contrib/settings.html>
- <https://docs.wagtail.org/en/stable/reference/pages/panels.html#wagtail.admin.panels.FieldPanel.permission>
- <https://github.com/wagtail/wagtail>
- <https://github.com/wagtail/wagtail/releases/tag/v6.0.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w2v8-php4-p8hc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w2v8-php4-p8hc/>. Everything for agents: <https://agentprime.io/llms.txt>.
