# View name validation bypass in Jenkins

Advisory record · `GHSA-w2hv-rcqr-2h7r`

- **Identifiers:** `GHSA-w2hv-rcqr-2h7r` · `BIT-jenkins-2021-21640` · `CVE-2021-21640`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-240](https://cwe.mitre.org/data/definitions/240.html)
- **Tags:** [CWE-240](https://agentprime.io/advisories/tag/cwe-240.md)
- **Published:** 24 May 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 17:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.jenkins-ci.main:jenkins-core` (Maven): affected `<2.277.2 || >=2.278, <2.287`; fixed in `2.277.2`, `2.287`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.019, the 79th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-w2hv-rcqr-2h7r](https://github.com/advisories/GHSA-w2hv-rcqr-2h7r)
- [OSV: GHSA-w2hv-rcqr-2h7r](https://osv.dev/vulnerability/GHSA-w2hv-rcqr-2h7r)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-21640>
- <https://github.com/jenkinsci/jenkins/commit/42e2c74049ddf5e0aca1fe6aadc7b24fdabb5494>
- <https://github.com/jenkinsci/jenkins>
- <https://www.jenkins.io/security/advisory/2021-04-07/#SECURITY-1871>
- <http://www.openwall.com/lists/oss-security/2021/04/07/2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w2hv-rcqr-2h7r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w2hv-rcqr-2h7r/>. Everything for agents: <https://agentprime.io/llms.txt>.
