# Unsafe Identifiers in Opencast

Advisory record · `GHSA-w29m-fjp4-qhmq`

- **Identifiers:** `GHSA-w29m-fjp4-qhmq` · `CVE-2020-5230`
- **State:** Confirmed
- **Severity:** CVSS 7.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-99](https://cwe.mitre.org/data/definitions/99.html)
- **Tags:** [CWE-99](https://agentprime.io/advisories/tag/cwe-99.md)
- **Published:** 30 Jan 2020
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Jan 2020, 21:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.opencastproject:base` (Maven): affected `<7.6 || >=8.0, <8.1`; fixed in `7.6`, `8.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Opencast (org.opencastproject:base) versions below 7.6 and versions 8.0 up to but not including 8.1 allow almost arbitrary identifiers for media packages and elements, which some file system operations use. An attacker who can supply such identifiers may be able to escape working directories and write files to other locations. Upgrade to Opencast 7.6 or 8.1. No workaround is listed.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.7 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-w29m-fjp4-qhmq)

## Sources

- [GitHub Advisory Database: GHSA-w29m-fjp4-qhmq](https://github.com/advisories/GHSA-w29m-fjp4-qhmq)
- [OSV: GHSA-w29m-fjp4-qhmq](https://osv.dev/vulnerability/GHSA-w29m-fjp4-qhmq)
- <https://github.com/opencast/opencast/security/advisories/GHSA-w29m-fjp4-qhmq>
- <https://nvd.nist.gov/vuln/detail/CVE-2020-5230>
- <https://github.com/opencast/opencast/commit/bbb473f34ab95497d6c432c81285efb0c739f317>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-w29m-fjp4-qhmq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-w29m-fjp4-qhmq/>. Everything for agents: <https://agentprime.io/llms.txt>.
