# Flight: HTTP method override enabled by default, facilitating CSRF escalation and middleware bypass

Advisory record · `GHSA-vxrr-w42w-w76g`

- **Identifiers:** `GHSA-vxrr-w42w-w76g` · `CVE-2026-42551` · `PKSA-w12s-8pdm-4hrq`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 6 May 2026
- **Updated:** 14 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 May 2026, 21:38 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `flightphp/core` (Packagist): affected `<3.18.1`; fixed in `3.18.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The flightphp/core Packagist package, versions before 3.18.1, honors the X-HTTP-Method-Override header and the \_method parameter on any HTTP verb, including GET, so a GET request can be treated as DELETE or PUT. An attacker can exploit this with a crafted link or page that triggers a request on a victim's browser, which can reach destructive routes and bypass middleware gated on unsafe verbs. Upgrade to 3.18.1, where the new flight.allow_method_override setting can be set to false to disable both override methods.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vxrr-w42w-w76g)

## Sources

- [GitHub Advisory Database: GHSA-vxrr-w42w-w76g](https://github.com/advisories/GHSA-vxrr-w42w-w76g)
- [OSV: GHSA-vxrr-w42w-w76g](https://osv.dev/vulnerability/GHSA-vxrr-w42w-w76g)
- <https://github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42551>
- <https://github.com/flightphp/core/commit/b8dd23aaa828cb289fa3c84e75b2a3717cab50b0>
- <https://github.com/flightphp/core>
- <https://github.com/flightphp/core/releases/tag/v3.18.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vxrr-w42w-w76g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vxrr-w42w-w76g/>. Everything for agents: <https://agentprime.io/llms.txt>.
