# Vyper's nonpayable default functions are sometimes payable

Advisory record · `GHSA-vxmm-cwh2-q762`

- **Identifiers:** `GHSA-vxmm-cwh2-q762` · `CVE-2023-32675` · `PYSEC-2023-80`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 22 May 2023
- **Updated:** 22 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 May 2023, 20:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vyper` (PyPI): affected `<0.3.8`; fixed in `0.3.8`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0055, the 46th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 22 May 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-vxmm-cwh2-q762](https://github.com/advisories/GHSA-vxmm-cwh2-q762)
- [OSV: GHSA-vxmm-cwh2-q762](https://osv.dev/vulnerability/GHSA-vxmm-cwh2-q762)
- <https://github.com/vyperlang/vyper/security/advisories/GHSA-vxmm-cwh2-q762>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-32675>
- <https://github.com/vyperlang/vyper/commit/02339dfda0f3caabad142060d511d10bfe93c520>
- <https://github.com/vyperlang/vyper/commit/02339dfda0f3caabad142060d511d10bfe93c520.>
- <https://github.com/vyperlang/vyper/commit/903727006c1e5ebef99fa9fd5d51d62bd33d72a9>
- <https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2023-80.yaml>
- <https://github.com/vyperlang/vyper>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vxmm-cwh2-q762>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vxmm-cwh2-q762/>. Everything for agents: <https://agentprime.io/llms.txt>.
