# Backstage has improper input validation in scaffolder task list ordering

Advisory record · `GHSA-vwp5-f99x-x3rq`

- **Identifiers:** `GHSA-vwp5-f99x-x3rq` · `CVE-2026-106506`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-202](https://cwe.mitre.org/data/definitions/202.html) · [CWE-203](https://cwe.mitre.org/data/definitions/203.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-202](https://agentprime.io/advisories/tag/cwe-202.md)
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2026, 16:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@backstage/plugin-scaffolder-backend` (npm): affected `<4.1.0`; fixed in `4.1.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The npm package @backstage/plugin-scaffolder-backend before 4.1.0 has improper input validation in scaffolder task list ordering. An authenticated user with permission to create and read scaffolder tasks may be able to infer confidential task data under specific conditions, such as retained task secrets, visibility of the target task, and repeated requests. Upgrade to version 4.1.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vwp5-f99x-x3rq)

## Sources

- [GitHub Advisory Database: GHSA-vwp5-f99x-x3rq](https://github.com/advisories/GHSA-vwp5-f99x-x3rq)
- [OSV: GHSA-vwp5-f99x-x3rq](https://osv.dev/vulnerability/GHSA-vwp5-f99x-x3rq)
- <https://github.com/backstage/backstage/security/advisories/GHSA-vwp5-f99x-x3rq>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-106506>
- <https://github.com/backstage/backstage/commit/e673a869449874a9169e8f89852e75e862011b93>
- <https://github.com/backstage/backstage>
- <https://github.com/backstage/backstage/releases/tag/v1.54.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vwp5-f99x-x3rq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vwp5-f99x-x3rq/>. Everything for agents: <https://agentprime.io/llms.txt>.
