# ArcadeDB: Scripting authorization gate (GHSA-48qw-824m-86pr) bypassed via SQL DEFINE FUNCTION ... LANGUAGE js

Advisory record · `GHSA-vwjc-v7x7-cm6g`

- **Identifiers:** `GHSA-vwjc-v7x7-cm6g` · `CVE-2026-67341`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-74](https://cwe.mitre.org/data/definitions/74.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Other injection](https://agentprime.io/advisories/tag/injection.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 16 Jul 2026
- **Updated:** 2 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Jul 2026, 20:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `com.arcadedb:arcadedb-engine` (Maven): affected `<26.7.2`; fixed in `26.7.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> ArcadeDB (com.arcadedb:arcadedb-engine) before 26.7.2 lets any user authorized for a database, including a read-only role, run arbitrary JavaScript through SQL DEFINE FUNCTION statements. This bypasses the restriction meant to limit scripting to security administrators and allows server-side requests to chosen URLs and unbounded CPU and memory use. Upgrade to 26.7.2.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vwjc-v7x7-cm6g)

## Sources

- [GitHub Advisory Database: GHSA-vwjc-v7x7-cm6g](https://github.com/advisories/GHSA-vwjc-v7x7-cm6g)
- [OSV: GHSA-vwjc-v7x7-cm6g](https://osv.dev/vulnerability/GHSA-vwjc-v7x7-cm6g)
- <https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-vwjc-v7x7-cm6g>
- <https://github.com/ArcadeData/arcadedb>
- <https://github.com/ArcadeData/arcadedb/releases/tag/26.7.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vwjc-v7x7-cm6g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vwjc-v7x7-cm6g/>. Everything for agents: <https://agentprime.io/llms.txt>.
