# JupyterLab LaTeX typesetter links did not enforce \`noopener\` attribute

Advisory record · `GHSA-vvfj-2jqx-52jm`

- **Identifiers:** `GHSA-vvfj-2jqx-52jm` · `BIT-jupyterlab-2025-59842` · `CVE-2025-59842` · `PYSEC-2026-1482`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-1022](https://cwe.mitre.org/data/definitions/1022.html)
- **Tags:** [CWE-1022](https://agentprime.io/advisories/tag/cwe-1022.md)
- **Published:** 26 Sept 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Sept 2025, 14:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jupyterlab` (PyPI): affected `<4.4.8`; fixed in `4.4.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> JupyterLab versions before 4.4.8 do not add the noopener attribute to links generated by LaTeX typesetters in Markdown files and cells. The source says this has no impact on default installations, and a reverse tabnabbing risk exists only with third-party LaTeX extensions that open links in a new tab. Upgrade to JupyterLab 4.4.8, which enforces noopener on these links.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 15th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vvfj-2jqx-52jm)

## Sources

- [GitHub Advisory Database: GHSA-vvfj-2jqx-52jm](https://github.com/advisories/GHSA-vvfj-2jqx-52jm)
- [OSV: GHSA-vvfj-2jqx-52jm](https://osv.dev/vulnerability/GHSA-vvfj-2jqx-52jm)
- <https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-vvfj-2jqx-52jm>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-59842>
- <https://github.com/jupyterlab/jupyterlab/commit/88ef373039a8cc09f27d3814382a512d9033675c>
- <https://github.com/jupyterlab/jupyterlab>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vvfj-2jqx-52jm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vvfj-2jqx-52jm/>. Everything for agents: <https://agentprime.io/llms.txt>.
