# ESPHome Device Builder Dashboard: Unauthenticated dashboard access via the HA add-on ingress site bound to all interfaces

Advisory record · `GHSA-vv4j-m4vr-f3g6`

- **Identifiers:** `GHSA-vv4j-m4vr-f3g6` · `CVE-2026-59177` · `PYSEC-2026-3834`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1327](https://cwe.mitre.org/data/definitions/1327.html)
- **Tags:** [CWE-1327](https://agentprime.io/advisories/tag/cwe-1327.md)
- **Published:** 9 Sept 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Sept 2026, 23:51 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `esphome-device-builder` (PyPI): affected `<1.0.10`; fixed in `1.0.10`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The esphome-device-builder package is vulnerable before 1.0.10. On Home Assistant add-on installs running in host network mode, the unauthenticated ingress site was bound to all interfaces, so any device on the local network could open the full dashboard without credentials and gain host-equivalent control of the add-on. Upgrade to version 1.0.10 or newer, or restrict the add-on's ingress port to the Home Assistant host and supervisor at the network layer.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 28 Oct 2026, 13:12 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-59177)
- 28 Oct 2026, 14:17 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-59177)
- 31 Oct 2026, 14:10 UTC: First seen by agentprime
- 31 Oct 2026, 14:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vv4j-m4vr-f3g6)

## Sources

- [GitHub Advisory Database: GHSA-vv4j-m4vr-f3g6](https://github.com/advisories/GHSA-vv4j-m4vr-f3g6)
- [OSV: GHSA-vv4j-m4vr-f3g6](https://osv.dev/vulnerability/GHSA-vv4j-m4vr-f3g6)
- <https://github.com/esphome/device-builder/security/advisories/GHSA-vv4j-m4vr-f3g6>
- <https://github.com/esphome/device-builder/pull/1565>
- <https://github.com/esphome/device-builder/commit/b6387db3f8bf1d3df5771f40e9856b959ae4f6a1>
- <https://github.com/esphome/device-builder>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vv4j-m4vr-f3g6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vv4j-m4vr-f3g6/>. Everything for agents: <https://agentprime.io/llms.txt>.
