# node-red-dashboard vulnerable to Cross-site Scripting

Advisory record · `GHSA-vrv9-3x3w-ffxw`

- **Identifiers:** `GHSA-vrv9-3x3w-ffxw` · `CVE-2022-3783`
- **State:** Confirmed
- **Severity:** CVSS 3.5 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-707](https://cwe.mitre.org/data/definitions/707.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-707](https://agentprime.io/advisories/tag/cwe-707.md)
- **Published:** 1 Nov 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Nov 2022, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `node-red-dashboard` (npm): affected `<3.2.0`; fixed in `3.2.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.5 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`, from CNA (VulDB)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0083, the 57th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 1 Nov 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-vrv9-3x3w-ffxw](https://github.com/advisories/GHSA-vrv9-3x3w-ffxw)
- [OSV: GHSA-vrv9-3x3w-ffxw](https://osv.dev/vulnerability/GHSA-vrv9-3x3w-ffxw)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-3783>
- <https://github.com/node-red/node-red-dashboard/issues/772>
- <https://github.com/node-red/node-red-dashboard/commit/9305d1a82f19b235dfad24a7d1dd4ed244db7743>
- <https://github.com/node-red/node-red-dashboard>
- <https://vuldb.com/?id.212555>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vrv9-3x3w-ffxw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vrv9-3x3w-ffxw/>. Everything for agents: <https://agentprime.io/llms.txt>.
