# Heap-based Buffer Overflow in sqlite-vec

Advisory record · `GHSA-vrcx-gx3g-j3h8`

- **Identifiers:** `GHSA-vrcx-gx3g-j3h8` · `CVE-2024-46488` · `PYSEC-2026-1938`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-122](https://cwe.mitre.org/data/definitions/122.html) · [CWE-787](https://cwe.mitre.org/data/definitions/787.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 25 Sept 2024
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Sept 2024, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `sqlite-vec` (PyPI): affected `<0.1.3`; fixed in `0.1.3`
- `sqlite-vec` (npm): affected `<0.1.3`; fixed in `0.1.3`
- `sqlite-vec` (RubyGems): affected `<0.1.3`; fixed in `0.1.3`
- `sqlite-vec` (crates.io): affected `<0.1.3`; fixed in `0.1.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 25 Sept 2024. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-vrcx-gx3g-j3h8](https://github.com/advisories/GHSA-vrcx-gx3g-j3h8)
- [OSV: GHSA-vrcx-gx3g-j3h8](https://osv.dev/vulnerability/GHSA-vrcx-gx3g-j3h8)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-46488>
- <https://github.com/VulnSphere/LLMVulnSphere/blob/main/VectorDB/sqlite-vec/OOBR_2.md>
- <https://github.com/advisories/GHSA-vrcx-gx3g-j3h8>
- <https://github.com/asg017/sqlite-vec>
- <https://github.com/asg017/sqlite-vec/releases/tag/v0.1.3>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sqlite-vec/CVE-2024-46488.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vrcx-gx3g-j3h8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vrcx-gx3g-j3h8/>. Everything for agents: <https://agentprime.io/llms.txt>.
