# Apache Syncope Vulnerable to Exposure of Sensitive Information Through Data Queries

Advisory record · `GHSA-vr35-jm2f-8wg2`

- **Identifiers:** `GHSA-vr35-jm2f-8wg2` · `CVE-2026-42797`
- **State:** Confirmed
- **Severity:** CVSS 4.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-202](https://cwe.mitre.org/data/definitions/202.html)
- **Tags:** [CWE-202](https://agentprime.io/advisories/tag/cwe-202.md)
- **Published:** 26 May 2026
- **Updated:** 30 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 May 2026, 13:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.syncope.core:syncope-core-provisioning-api` (Maven): affected `>=3.0.0-M0, <=3.0.16 || >=4.0.0-M0, <4.0.6 || >=4.1.0-M0, <4.1.1`; fixed in `4.0.6`, `4.1.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Syncope's syncope-core-provisioning-api package is affected in versions 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.5, and 4.1.0. An administrator who has rights to manage Derived Schemas can craft a malicious JEXL expression that lets another administrator with User read permission access security-sensitive user information. Upgrade to 4.0.6 or 4.1.1, which further restrict the JEXL expression definition.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0044, the 38th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vr35-jm2f-8wg2)

## Sources

- [GitHub Advisory Database: GHSA-vr35-jm2f-8wg2](https://github.com/advisories/GHSA-vr35-jm2f-8wg2)
- [OSV: GHSA-vr35-jm2f-8wg2](https://osv.dev/vulnerability/GHSA-vr35-jm2f-8wg2)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42797>
- <https://github.com/apache/syncope>
- <https://lists.apache.org/thread/5y7d277sntyytrmxnx2tfjr9ftcpq1s6>
- <http://www.openwall.com/lists/oss-security/2026/05/25/5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vr35-jm2f-8wg2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vr35-jm2f-8wg2/>. Everything for agents: <https://agentprime.io/llms.txt>.
