# NATS has pre-auth server panic via leafnode handling

Advisory record · `GHSA-vprv-35vv-q339`

- **Identifiers:** `GHSA-vprv-35vv-q339` · `BIT-nats-2026-33218` · `CVE-2026-33218` · `GO-2026-4837`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-1286](https://cwe.mitre.org/data/definitions/1286.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-1286](https://agentprime.io/advisories/tag/cwe-1286.md)
- **Published:** 24 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Mar 2026, 21:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/nats-io/nats-server/v2` (Go): affected `<2.11.15 || >=2.12.0-RC.1, <2.12.6`; fixed in `2.11.15`, `2.12.6`
- `github.com/nats-io/nats-server` (Go): affected `all versions`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> NATS server (github.com/nats-io/nats-server/v2) versions before 2.11.15, and 2.12.0-RC.1 up to but not including 2.12.6, are vulnerable. A client that can reach the leafnode port can crash the server before authenticating by sending a malformed message. Upgrade to 2.11.15 or 2.12.6. If you do not need leafnode support, disable it, or restrict network access to the leafnode port.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0063, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vprv-35vv-q339)

## Sources

- [GitHub Advisory Database: GHSA-vprv-35vv-q339](https://github.com/advisories/GHSA-vprv-35vv-q339)
- [OSV: GHSA-vprv-35vv-q339](https://osv.dev/vulnerability/GHSA-vprv-35vv-q339)
- <https://github.com/nats-io/nats-server/security/advisories/GHSA-vprv-35vv-q339>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33218>
- <https://advisories.nats.io/CVE/secnote-2026-10.txt>
- <https://github.com/nats-io/nats-server>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vprv-35vv-q339>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vprv-35vv-q339/>. Everything for agents: <https://agentprime.io/llms.txt>.
