# Twisted: Unauthenticated Remote Denial of Service in the Twisted HTTP/2 Server via Rapid Stream Reset

Advisory record · `GHSA-vpp8-g58w-m8mp`

- **Identifiers:** `GHSA-vpp8-g58w-m8mp`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Oct 2026, 16:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `twisted` (PyPI): affected `<26.10.0rc1`; fixed in `26.10.0rc1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Twisted's HTTP/2 server, in versions before 26.10.0rc1, is vulnerable to a denial of service: an unauthenticated remote client can open one connection, send request headers with END_STREAM and immediately reset the stream, and repeat this so the server renders each request and consumes CPU. The attack needs only network access to a Twisted HTTP/2 endpoint and no credentials, and the source says it can saturate a CPU core over a single connection. The fix is to upgrade to Twisted 26.10.0rc1 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vpp8-g58w-m8mp)

## Sources

- [GitHub Advisory Database: GHSA-vpp8-g58w-m8mp](https://github.com/advisories/GHSA-vpp8-g58w-m8mp)
- [OSV: GHSA-vpp8-g58w-m8mp](https://osv.dev/vulnerability/GHSA-vpp8-g58w-m8mp)
- <https://github.com/twisted/twisted/security/advisories/GHSA-vpp8-g58w-m8mp>
- <https://github.com/twisted/twisted/pull/12749>
- <https://github.com/twisted/twisted/commit/498939422b69d5a75c4b8f81fa7926423dac534d>
- <https://github.com/twisted/twisted>
- <https://github.com/twisted/twisted/releases/tag/twisted-26.10.0rc1>
- <https://nvd.nist.gov/vuln/detail/cve-2023-44487>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vpp8-g58w-m8mp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vpp8-g58w-m8mp/>. Everything for agents: <https://agentprime.io/llms.txt>.
