# Exposure of Resource to Wrong Sphere and Insecure Temporary File in Ansible

Advisory record · `GHSA-vp9j-rghq-8jhh`

- **Identifiers:** `GHSA-vp9j-rghq-8jhh` · `CVE-2020-10744` · `PYSEC-2020-208`
- **State:** Confirmed
- **Severity:** CVSS 5.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-362](https://cwe.mitre.org/data/definitions/362.html) · [CWE-377](https://cwe.mitre.org/data/definitions/377.html) · [CWE-668](https://cwe.mitre.org/data/definitions/668.html)
- **Tags:** [Race condition](https://agentprime.io/advisories/tag/race-condition.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 9 Feb 2022
- **Updated:** 20 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Feb 2022, 21:59 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ansible` (PyPI): affected `>=2.10.0a1, <2.10.0rc1 || <2.9.12`; fixed in `2.10.0rc1`, `2.9.12`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.0 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 9 Feb 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-vp9j-rghq-8jhh](https://github.com/advisories/GHSA-vp9j-rghq-8jhh)
- [OSV: GHSA-vp9j-rghq-8jhh](https://osv.dev/vulnerability/GHSA-vp9j-rghq-8jhh)
- <https://nvd.nist.gov/vuln/detail/CVE-2020-10744>
- <https://github.com/ansible/ansible/issues/69782>
- <https://github.com/ansible/ansible/commit/77d0effcc5b2da1ef23e4ba32986a9759c27c10d>
- <https://github.com/ansible/ansible/commit/84afa8e90cd168ff13208c8eae3e533ce7e21e1f>
- <https://github.com/ansible/ansible/commit/ffd3757fc35468a97791e452e7f2d14c3e3fcb80>
- <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10744>
- <https://github.com/advisories/GHSA-vp9j-rghq-8jhh>
- <https://github.com/ansible/ansible>
- <https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-208.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vp9j-rghq-8jhh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vp9j-rghq-8jhh/>. Everything for agents: <https://agentprime.io/llms.txt>.
