# undici vulnerable to cross-origin cache poisoning via missing origin isolation in interceptors

Advisory record · `GHSA-vp8m-p9jh-q5pm`

- **Identifiers:** `GHSA-vp8m-p9jh-q5pm` · `CVE-2026-85152`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-346](https://cwe.mitre.org/data/definitions/346.html)
- **Tags:** [CWE-346](https://agentprime.io/advisories/tag/cwe-346.md)
- **Published:** 29 Sept 2026
- **Updated:** 29 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Sept 2026, 18:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `undici` (npm): affected `>=8.10.0, <8.10.2`; fixed in `8.10.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The undici npm package, versions 8.10.0 up to but not including 8.10.2, builds cache and deduplication keys without the destination origin when interceptors.cache() or interceptors.deduplicate() is used with a shared store or instance across origins. An attacker who controls the response from one origin can have it returned for a matching request to a different, trusted origin, enabling cross-origin information disclosure and cache poisoning, such as JWKS poisoning. Upgrade to undici 8.10.2; until then, use a separate cache store and interceptor instance for each origin.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0016, the 5th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vp8m-p9jh-q5pm)

## Sources

- [GitHub Advisory Database: GHSA-vp8m-p9jh-q5pm](https://github.com/advisories/GHSA-vp8m-p9jh-q5pm)
- [OSV: GHSA-vp8m-p9jh-q5pm](https://osv.dev/vulnerability/GHSA-vp8m-p9jh-q5pm)
- <https://github.com/nodejs/undici/security/advisories/GHSA-vp8m-p9jh-q5pm>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-85152>
- <https://github.com/nodejs/undici/commit/caf6194d3dae989b731ed87ab85f182befe5eb80>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/nodejs/undici>
- <https://github.com/nodejs/undici/releases/tag/v8.10.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vp8m-p9jh-q5pm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vp8m-p9jh-q5pm/>. Everything for agents: <https://agentprime.io/llms.txt>.
