# netty-incubator-codec-ohttp: \[OHttpServerCodec\] Native Direct-Memory Leak on AEAD Decryption Failure Leads to Gateway Denial of Service

Advisory record · `GHSA-vmr9-j6wf-pmh2`

- **Identifiers:** `GHSA-vmr9-j6wf-pmh2` · `CVE-2026-54251`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-664](https://cwe.mitre.org/data/definitions/664.html)
- **Tags:** [CWE-664](https://agentprime.io/advisories/tag/cwe-664.md)
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty.incubator:netty-incubator-codec-ohttp` (Maven): affected `<0.0.23.Final`; fixed in `0.0.23.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of netty-incubator-codec-ohttp before 0.0.23.Final are affected. When the OHTTP gateway receives an encrypted request that fails AEAD tag verification, a native direct-memory buffer allocated for the plaintext is never released, so an unauthenticated remote client can repeatedly send invalid ciphertext to exhaust native memory and cause a denial of service. Upgrade to 0.0.23.Final or later. The source gives few details on any workaround.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vmr9-j6wf-pmh2)

## Sources

- [GitHub Advisory Database: GHSA-vmr9-j6wf-pmh2](https://github.com/advisories/GHSA-vmr9-j6wf-pmh2)
- [OSV: GHSA-vmr9-j6wf-pmh2](https://osv.dev/vulnerability/GHSA-vmr9-j6wf-pmh2)
- <https://github.com/netty/netty-incubator-codec-ohttp/security/advisories/GHSA-vmr9-j6wf-pmh2>
- <https://github.com/netty/netty-incubator-codec-ohttp>
- <https://github.com/netty/netty-incubator-codec-ohttp/releases/tag/netty-incubator-codec-parent-ohttp-0.0.23.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vmr9-j6wf-pmh2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vmr9-j6wf-pmh2/>. Everything for agents: <https://agentprime.io/llms.txt>.
