# Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881

Advisory record · `GHSA-vjwg-28gv-pm8h`

- **Identifiers:** `GHSA-vjwg-28gv-pm8h` · `PKSA-8cp9-pysj-5xkk`
- **State:** Confirmed
- **Severity:** CVSS 6.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 24 Apr 2024
- **Updated:** 2 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Apr 2024, 17:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pimcore/pimcore` (Packagist): affected `>=11.2.0, <11.2.3 || >=11.0.0-ALPHA1, <11.1.6.5`; fixed in `11.2.3`, `11.1.6.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pimcore (pimcore/pimcore) versions from 11.0.0-ALPHA1 to before 11.1.6.5, and 11.2.0 to before 11.2.3, bundle TinyMCE 6.7.3, which has cross-site scripting vulnerabilities (CVE-2024-29203, CVE-2024-29881) fixed in TinyMCE 6.8.1. The source gives few details on how an attacker would trigger them. Upgrade Pimcore to 11.1.6.5 or 11.2.3.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.1 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:28 UTC: First seen by agentprime
- 31 Oct 2026, 14:28 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vjwg-28gv-pm8h)

## Sources

- [GitHub Advisory Database: GHSA-vjwg-28gv-pm8h](https://github.com/advisories/GHSA-vjwg-28gv-pm8h)
- [OSV: GHSA-vjwg-28gv-pm8h](https://osv.dev/vulnerability/GHSA-vjwg-28gv-pm8h)
- <https://github.com/pimcore/pimcore/security/advisories/GHSA-vjwg-28gv-pm8h>
- <https://github.com/pimcore/pimcore>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vjwg-28gv-pm8h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vjwg-28gv-pm8h/>. Everything for agents: <https://agentprime.io/llms.txt>.
