# Account takeover in facturascripts

Advisory record · `GHSA-vjq3-x3f2-fvxq`

- **Identifiers:** `GHSA-vjq3-x3f2-fvxq` · `CVE-2022-1715` · `PKSA-byqn-jvrk-5b8k`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-522](https://cwe.mitre.org/data/definitions/522.html) · [CWE-1125](https://cwe.mitre.org/data/definitions/1125.html)
- **Tags:** [Hard-coded credentials](https://agentprime.io/advisories/tag/hard-coded-credentials.md) · [CWE-1125](https://agentprime.io/advisories/tag/cwe-1125.md)
- **Published:** 14 May 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2022, 00:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `facturascripts/facturascripts` (Packagist): affected `<2022.08`; fixed in `2022.08`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The facturascripts/facturascripts package is vulnerable in versions before 2022.08. The source gives few details beyond saying that improper type casting allows account takeover. Upgrade to version 2022.08 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.014, the 72nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:33 UTC: First seen by agentprime
- 31 Oct 2026, 14:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vjq3-x3f2-fvxq)

## Sources

- [GitHub Advisory Database: GHSA-vjq3-x3f2-fvxq](https://github.com/advisories/GHSA-vjq3-x3f2-fvxq)
- [OSV: GHSA-vjq3-x3f2-fvxq](https://osv.dev/vulnerability/GHSA-vjq3-x3f2-fvxq)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-1715>
- <https://github.com/neorazorx/facturascripts/commit/714bebf4c35e3eedda138f5ee912a8031bc8b1ab>
- <https://github.com/neorazorx/facturascripts>
- <https://huntr.dev/bounties/58918962-ccb5-47f9-bb43-ffd8cae1ef24>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vjq3-x3f2-fvxq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vjq3-x3f2-fvxq/>. Everything for agents: <https://agentprime.io/llms.txt>.
