# Moodle has arbitrary file read risk through pdfTeX

Advisory record · `GHSA-vjmm-r9gg-425m`

- **Identifiers:** `GHSA-vjmm-r9gg-425m` · `BIT-moodle-2024-43426` · `CVE-2024-43426` · `PKSA-c8xb-byc5-1chb`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 7 Nov 2024
- **Updated:** 6 Aug 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Nov 2024, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `<4.1.12 || >=4.2.0-beta, <4.2.9 || >=4.3.0-beta, <4.3.6 || >=4.4.0-beta, <4.4.2`; fixed in `4.1.12`, `4.2.9`, `4.3.6`, `4.4.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle versions before 4.1.12, from 4.2.0-beta before 4.2.9, from 4.3.0-beta before 4.3.6, and from 4.4.0-beta before 4.4.2 are affected. Insufficient sanitizing in the TeX notation filter can allow arbitrary file read on sites where pdfTeX is installed, such as those with TeX Live. Upgrade to 4.1.12, 4.2.9, 4.3.6, or 4.4.2, depending on your branch. The source gives few details about the exact attack conditions.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (fedora)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0071, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:27 UTC: First seen by agentprime
- 31 Oct 2026, 14:27 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vjmm-r9gg-425m)

## Sources

- [GitHub Advisory Database: GHSA-vjmm-r9gg-425m](https://github.com/advisories/GHSA-vjmm-r9gg-425m)
- [OSV: GHSA-vjmm-r9gg-425m](https://osv.dev/vulnerability/GHSA-vjmm-r9gg-425m)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-43426>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2304254>
- <https://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-82745>
- <https://github.com/moodle/moodle>
- <https://moodle.org/mod/forum/discuss.php?d=461194>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vjmm-r9gg-425m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vjmm-r9gg-425m/>. Everything for agents: <https://agentprime.io/llms.txt>.
