# GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule

Advisory record · `GHSA-vj8h-fx38-h3vc`

- **Identifiers:** `GHSA-vj8h-fx38-h3vc` · `CVE-2026-75507`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-407](https://cwe.mitre.org/data/definitions/407.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Oct 2026, 16:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `graphql-core` (PyPI): affected `>=3.0.0, <3.2.12 || >=3.3.0a1, <3.3.0rc1`; fixed in `3.2.12`, `3.3.0rc1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GraphQL-core (PyPI package graphql-core) versions 3.0.0 up to but not including 3.2.12, and 3.3.0a1 up to but not including 3.3.0rc1, are vulnerable. A single small, highly compressible query can make the OverlappingFieldsCanBeMerged validation rule run for minutes on one CPU core, enabling denial of service by unauthenticated remote requests. Upgrade to graphql-core 3.2.12 or 3.3.0rc1, which cap the number of field comparisons per document. Until then, reject oversized documents after decompression before they reach validation.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0060, the 48th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vj8h-fx38-h3vc)

## Sources

- [GitHub Advisory Database: GHSA-vj8h-fx38-h3vc](https://github.com/advisories/GHSA-vj8h-fx38-h3vc)
- [OSV: GHSA-vj8h-fx38-h3vc](https://osv.dev/vulnerability/GHSA-vj8h-fx38-h3vc)
- <https://github.com/graphql-python/graphql-core/security/advisories/GHSA-vj8h-fx38-h3vc>
- <https://github.com/graphql-python/graphql-core/commit/150e59814d97d12140be005a558c93188ef89198>
- <https://github.com/graphql-python/graphql-core/commit/29c2753a7ee30a96a4109e7c6add1a2dae0497d7>
- <https://github.com/graphql-python/graphql-core>
- <https://github.com/graphql-python/graphql-core/releases/tag/v3.2.12>
- <https://github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vj8h-fx38-h3vc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vj8h-fx38-h3vc/>. Everything for agents: <https://agentprime.io/llms.txt>.
