# MLFlow path traversal vulnerability

Advisory record · `GHSA-vhcx-3pq2-4fvc`

- **Identifiers:** `GHSA-vhcx-3pq2-4fvc` · `BIT-mlflow-2025-15036` · `CVE-2025-15036` · `PYSEC-2026-425`
- **State:** Confirmed
- **Severity:** CVSS 9.6 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-29](https://cwe.mitre.org/data/definitions/29.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-29](https://agentprime.io/advisories/tag/cwe-29.md)
- **Published:** 30 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Mar 2026, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.6: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `mlflow` (PyPI): affected `<3.9.0rc0`; fixed in `3.9.0rc0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> mlflow versions before 3.9.0rc0 are vulnerable to path traversal during tar archive extraction, because tar member paths are not validated. An attacker who controls a tar.gz file can overwrite arbitrary files and potentially gain elevated privileges. Upgrade to mlflow 3.9.0rc0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.6 Critical, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vhcx-3pq2-4fvc)

## Sources

- [GitHub Advisory Database: GHSA-vhcx-3pq2-4fvc](https://github.com/advisories/GHSA-vhcx-3pq2-4fvc)
- [OSV: GHSA-vhcx-3pq2-4fvc](https://osv.dev/vulnerability/GHSA-vhcx-3pq2-4fvc)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-15036>
- <https://github.com/mlflow/mlflow/commit/3bf6d81ac4d38654c8ff012dbd0c3e9f17e7e346>
- <https://github.com/mlflow/mlflow>
- <https://huntr.com/bounties/36c314cf-fd6e-4fb0-b9b0-1b47bcdf0eb0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vhcx-3pq2-4fvc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vhcx-3pq2-4fvc/>. Everything for agents: <https://agentprime.io/llms.txt>.
