# Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences

Advisory record · `GHSA-vfww-5hm6-hx2j`

- **Identifiers:** `GHSA-vfww-5hm6-hx2j` · `BIT-tomcat-2025-55754` · `CVE-2025-55754`
- **State:** Confirmed
- **Severity:** CVSS 9.6 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 27 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2025, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.6: 9.0 or more.
- CVSS score 9.6 (7.0 or more) and EPSS 0.10 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.tomcat:tomcat` (Maven): affected `>=11.0.0-M1, <11.0.11 || >=10.1.0-M1, <10.1.45 || >=9.0.40, <9.0.109 || >=8.5.60, <=8.5.100`; fixed in `11.0.11`, `10.1.45`, `9.0.109`
- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=11.0.0-M1, <11.0.11 || >=10.1.0-M1, <10.1.45 || >=9.0.40, <9.0.109 || >=8.5.60, <=8.5.100`; fixed in `11.0.11`, `10.1.45`, `9.0.109`
- `org.apache.tomcat:tomcat-catalina` (Maven): affected `>=11.0.0-M1, <11.0.11 || >=10.1.0-M1, <10.1.45 || >=9.0.40, <9.0.109 || >=8.5.60, <=8.5.100`; fixed in `11.0.11`, `10.1.45`, `9.0.109`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat (org.apache.tomcat:tomcat, tomcat-embed-core and tomcat-catalina) is affected from 11.0.0-M1 through 11.0.10, 10.1.0-M1 through 10.1.44, 9.0.40 through 9.0.108, and 8.5.60 through 8.5.100. Tomcat did not escape ANSI escape sequences in log messages, so an attacker using a crafted URL could inject them into a Windows console that supports them, potentially manipulating the console and clipboard to trick an administrator into running a command. Upgrade to 11.0.11, 10.1.45, or 9.0.109 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.6 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.10, the 95th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vfww-5hm6-hx2j)

## Sources

- [GitHub Advisory Database: GHSA-vfww-5hm6-hx2j](https://github.com/advisories/GHSA-vfww-5hm6-hx2j)
- [OSV: GHSA-vfww-5hm6-hx2j](https://osv.dev/vulnerability/GHSA-vfww-5hm6-hx2j)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-55754>
- <https://github.com/apache/tomcat/commit/138d7f5cfaae683078948303333c080e6faa75d2>
- <https://github.com/apache/tomcat/commit/5a3db092982c0c58d4855304167ee757fe5e79bb>
- <https://github.com/apache/tomcat/commit/a03cabf3a36a42d27d8d997ed31f034f50ba6cd5>
- <https://cert-portal.siemens.com/productcert/html/ssa-032379.html>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/j7w54hqbkfcn0xb9xy0wnx8w5nymcbqd>
- <https://tomcat.apache.org/security-10.html#Fixed_in_Apache_Tomcat_10.1.45>
- <https://tomcat.apache.org/security-11.html#Fixed_in_Apache_Tomcat_11.0.11>
- <https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.109>
- <http://www.openwall.com/lists/oss-security/2025/10/27/5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vfww-5hm6-hx2j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vfww-5hm6-hx2j/>. Everything for agents: <https://agentprime.io/llms.txt>.
