# vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. At...

Advisory record · `GHSA-vfp2-c8pq-v6h6`

- **Identifiers:** `GHSA-vfp2-c8pq-v6h6` · `CVE-2026-116176` · `PYSEC-2026-4351`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 25 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Oct 2026, 14:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.9.2, <0.24.0`; fixed in `0.24.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions from 0.9.2 before 0.24.0 contain a server-side request forgery flaw in which a decode address embedded in the X-Request-Id header can make the P2pNcclConnector prefill worker connect over ZMQ to an attacker-chosen host. An API caller who can send requests to the server could exploit this to leak the NCCL unique_id and KV-cache tensors or to block the worker. Upgrade vllm to version 0.24.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 25 Oct 2026, 13:20 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-116176)
- 25 Oct 2026, 14:16 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-116176)
- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-4351)

## Sources

- [GitHub Advisory Database: GHSA-vfp2-c8pq-v6h6](https://github.com/advisories/GHSA-vfp2-c8pq-v6h6)
- [OSV: GHSA-vfp2-c8pq-v6h6](https://osv.dev/vulnerability/GHSA-vfp2-c8pq-v6h6)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-vfp2-c8pq-v6h6>
- <https://www.vulncheck.com/advisories/vllm-0.9.2-before-0.24.0-ssrf-via-x-request-id-in-p2pncclconnector>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vfp2-c8pq-v6h6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vfp2-c8pq-v6h6/>. Everything for agents: <https://agentprime.io/llms.txt>.
