# Apache HTTP Server via mod_proxy_uwsgi HTTP response smuggling

Advisory record · `GHSA-vcph-37mh-fqrh`

- **Identifiers:** `GHSA-vcph-37mh-fqrh` · `BIT-apache-2023-27522` · `CVE-2023-27522` · `PYSEC-2026-1058`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 7 Mar 2023
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Mar 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `uwsgi` (PyPI): affected `<2.0.22`; fixed in `2.0.22`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.021, the 82nd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 7 Mar 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-vcph-37mh-fqrh](https://github.com/advisories/GHSA-vcph-37mh-fqrh)
- [OSV: GHSA-vcph-37mh-fqrh](https://osv.dev/vulnerability/GHSA-vcph-37mh-fqrh)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-27522>
- <https://github.com/apache/httpd/commit/d753ea76b5972a85349b68c31b59d04c60014f2d>
- <https://github.com/unbit/uwsgi/commit/58ee1df31fa9e9af106aaeabb82374c36b433822>
- <https://github.com/unbit/uwsgi/commit/acb03530aaaeaa810f28a5b64da619525940f569>
- <https://github.com/unbit/uwsgi>
- <https://httpd.apache.org/security/vulnerabilities_24.html>
- <https://lists.debian.org/debian-lts-announce/2023/04/msg00028.html>
- <https://security.gentoo.org/glsa/202309-01>
- <https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.22.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vcph-37mh-fqrh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vcph-37mh-fqrh/>. Everything for agents: <https://agentprime.io/llms.txt>.
