# Wasmtime may not properly enforce async-entrypoint requirement

Advisory record · `GHSA-vcg5-q8m5-8379`

- **Identifiers:** `GHSA-vcg5-q8m5-8379` · `CVE-2026-119136` · `RUSTSEC-2026-0362`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1265](https://cwe.mitre.org/data/definitions/1265.html)
- **Tags:** [CWE-1265](https://agentprime.io/advisories/tag/cwe-1265.md)
- **Published:** 14 Oct 2026
- **Updated:** 30 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Oct 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wasmtime` (crates.io): affected `>=42.0.0, <48.0.6 || >=49.0.0, <49.0.3`; fixed in `48.0.6`, `49.0.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Rust crate wasmtime is affected in versions 42.0.0 up to 48.0.6 and 49.0.0 up to 49.0.3. The source gives few details: it describes the issue only as a failure to properly enforce the async-entrypoint requirement, and does not say what an attacker must do or what impact follows. Upgrade wasmtime to 48.0.6 or 49.0.3, depending on the release line in use.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0021, the 11th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 29 Oct 2026, 15:58 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-119136)
- 29 Oct 2026, 16:18 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-119136)
- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0362)

## Sources

- [GitHub Advisory Database: GHSA-vcg5-q8m5-8379](https://github.com/advisories/GHSA-vcg5-q8m5-8379)
- [OSV: GHSA-vcg5-q8m5-8379](https://osv.dev/vulnerability/GHSA-vcg5-q8m5-8379)
- <https://crates.io/crates/wasmtime>
- <https://rustsec.org/advisories/RUSTSEC-2026-0362.html>
- <https://github.com/bytecodealliance/wasmtime/pull/14734>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vcg5-q8m5-8379>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vcg5-q8m5-8379/>. Everything for agents: <https://agentprime.io/llms.txt>.
