# Caddy: stripHTML template function bypass

Advisory record · `GHSA-vcc4-2c75-vc9v`

- **Identifiers:** `GHSA-vcc4-2c75-vc9v` · `CVE-2026-52846` · `GO-2026-5660`
- **State:** Confirmed
- **Severity:** CVSS 4.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 16 Jun 2026
- **Updated:** 24 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Jun 2026, 21:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/caddyserver/caddy/v2` (Go): affected `<2.11.4`; fixed in `2.11.4`
- `github.com/caddyserver/caddy` (Go): affected `<=1.0.5`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Caddy's stripHTML template function (github.com/caddyserver/caddy/v2 versions before 2.11.4) can fail to remove all HTML tags from malformed input, so some markup survives. If a template then renders that output as HTML, an attacker who controls the input could cause client-side cross-site scripting. Upgrade to version 2.11.4. The legacy github.com/caddyserver/caddy package, versions up to 1.0.5, is also affected and no fixed version is listed for it.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.2 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:56 UTC: First seen by agentprime
- 31 Oct 2026, 14:56 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vcc4-2c75-vc9v)

## Sources

- [GitHub Advisory Database: GHSA-vcc4-2c75-vc9v](https://github.com/advisories/GHSA-vcc4-2c75-vc9v)
- [OSV: GHSA-vcc4-2c75-vc9v](https://osv.dev/vulnerability/GHSA-vcc4-2c75-vc9v)
- <https://github.com/caddyserver/caddy/security/advisories/GHSA-vcc4-2c75-vc9v>
- <https://github.com/caddyserver/caddy>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vcc4-2c75-vc9v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vcc4-2c75-vc9v/>. Everything for agents: <https://agentprime.io/llms.txt>.
