# compression vulnerable to Denial of Service via memory leak on premature response close

Advisory record · `GHSA-vc2v-76pw-4v95`

- **Identifiers:** `GHSA-vc2v-76pw-4v95` · `CVE-2026-87776`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-401](https://cwe.mitre.org/data/definitions/401.html) · [CWE-459](https://cwe.mitre.org/data/definitions/459.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-459](https://agentprime.io/advisories/tag/cwe-459.md)
- **Published:** 5 Oct 2026
- **Updated:** 5 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 23:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `compression` (npm): affected `<1.8.2`; fixed in `1.8.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The npm package compression, versions before 1.8.2, is vulnerable to a denial of service caused by a memory leak when a client disconnects before a compressed response finishes. The zlib stream for each aborted response is never destroyed, so repeated aborted requests can exhaust memory; the source does not say whether any special access is needed beyond sending requests. Users should upgrade to compression 1.8.2, and the source lists no workarounds.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-vc2v-76pw-4v95)

## Sources

- [GitHub Advisory Database: GHSA-vc2v-76pw-4v95](https://github.com/advisories/GHSA-vc2v-76pw-4v95)
- [OSV: GHSA-vc2v-76pw-4v95](https://osv.dev/vulnerability/GHSA-vc2v-76pw-4v95)
- <https://github.com/expressjs/compression/security/advisories/GHSA-vc2v-76pw-4v95>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-87776>
- <https://github.com/expressjs/compression/commit/151f63e91e1b64f8fb0b064e19321a4f28db6bff>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/expressjs/compression>
- <https://github.com/expressjs/compression/releases/tag/v1.8.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-vc2v-76pw-4v95>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-vc2v-76pw-4v95/>. Everything for agents: <https://agentprime.io/llms.txt>.
