# ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware

Advisory record · `GHSA-v9xm-ffx2-7h35`

- **Identifiers:** `GHSA-v9xm-ffx2-7h35` · `CVE-2026-32730`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-305](https://cwe.mitre.org/data/definitions/305.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 18 Mar 2026
- **Updated:** 19 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Mar 2026, 19:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `apostrophe` (npm): affected `<4.28.0`; fixed in `4.28.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-v9xm-ffx2-7h35](https://github.com/advisories/GHSA-v9xm-ffx2-7h35)
- [OSV: GHSA-v9xm-ffx2-7h35](https://osv.dev/vulnerability/GHSA-v9xm-ffx2-7h35)
- <https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-v9xm-ffx2-7h35>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-32730>
- <https://github.com/apostrophecms/apostrophe>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v9xm-ffx2-7h35>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v9xm-ffx2-7h35/>. Everything for agents: <https://agentprime.io/llms.txt>.
