# @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Advisory record · `GHSA-v9ww-2j6r-98q6`

- **Identifiers:** `GHSA-v9ww-2j6r-98q6` · `CVE-2026-33804`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 16 Apr 2026
- **Updated:** 16 Apr 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Apr 2026, 22:28 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@fastify/middie` (npm): affected `<9.3.2`; fixed in `9.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Apr 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-v9ww-2j6r-98q6](https://github.com/advisories/GHSA-v9ww-2j6r-98q6)
- [OSV: GHSA-v9ww-2j6r-98q6](https://osv.dev/vulnerability/GHSA-v9ww-2j6r-98q6)
- <https://github.com/fastify/middie/security/advisories/GHSA-v9ww-2j6r-98q6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-33804>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/fastify/middie>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v9ww-2j6r-98q6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v9ww-2j6r-98q6/>. Everything for agents: <https://agentprime.io/llms.txt>.
