# PraisonAIAgents: Environment Variable Secret Exfiltration via os.path.expandvars() Bypassing shell=False in Shell Tool

Advisory record · `GHSA-v8g7-9q6v-p3x8`

- **Identifiers:** `GHSA-v8g7-9q6v-p3x8` · `CVE-2026-40153` · `PYSEC-2026-2953`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-526](https://cwe.mitre.org/data/definitions/526.html)
- **Tags:** [CWE-526](https://agentprime.io/advisories/tag/cwe-526.md)
- **Published:** 10 Apr 2026
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Apr 2026, 19:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `praisonaiagents` (PyPI): affected `<1.5.128`; fixed in `1.5.128`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> PraisonAIAgents versions before 1.5.128 are affected. The execute_command shell tool expands environment variable references in command arguments, so secrets such as database credentials and API keys can be read, while the approval prompt shows the unexpanded reference. An attacker who can influence the agent's tool calls, for example through prompt injection in processed content, could exfiltrate these values, and automated setups using auto-approval have no review step. Upgrade to version 1.5.128 or later.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:01 UTC: First seen by agentprime
- 31 Oct 2026, 15:01 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v8g7-9q6v-p3x8)

## Sources

- [GitHub Advisory Database: GHSA-v8g7-9q6v-p3x8](https://github.com/advisories/GHSA-v8g7-9q6v-p3x8)
- [OSV: GHSA-v8g7-9q6v-p3x8](https://osv.dev/vulnerability/GHSA-v8g7-9q6v-p3x8)
- <https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-v8g7-9q6v-p3x8>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40153>
- <https://github.com/MervinPraison/PraisonAI>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v8g7-9q6v-p3x8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v8g7-9q6v-p3x8/>. Everything for agents: <https://agentprime.io/llms.txt>.
