# pgjdbc Does Not Check Class Instantiation when providing Plugin Classes

Advisory record · `GHSA-v7wg-cpwc-24m4`

- **Identifiers:** `GHSA-v7wg-cpwc-24m4` · `BIT-postgresql-jdbc-driver-2022-21724` · `CVE-2022-21724`
- **State:** Confirmed
- **Severity:** CVSS 7.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-74](https://cwe.mitre.org/data/definitions/74.html) · [CWE-665](https://cwe.mitre.org/data/definitions/665.html) · [CWE-668](https://cwe.mitre.org/data/definitions/668.html)
- **Tags:** [Other injection](https://agentprime.io/advisories/tag/injection.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-665](https://agentprime.io/advisories/tag/cwe-665.md)
- **Published:** 2 Feb 2022
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Feb 2022, 00:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.postgresql:postgresql` (Maven): affected `>=9.4.1208, <42.2.25 || >=42.3.0, <42.3.2`; fixed in `42.2.25`, `42.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.0 High, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.031, the 87th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v7wg-cpwc-24m4)

## Sources

- [GitHub Advisory Database: GHSA-v7wg-cpwc-24m4](https://github.com/advisories/GHSA-v7wg-cpwc-24m4)
- [OSV: GHSA-v7wg-cpwc-24m4](https://osv.dev/vulnerability/GHSA-v7wg-cpwc-24m4)
- <https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-v7wg-cpwc-24m4>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-21724>
- <https://github.com/pgjdbc/pgjdbc/commit/f4d0ed69c0b3aae8531d83d6af4c57f22312c813>
- <https://github.com/pgjdbc/pgjdbc>
- <https://lists.debian.org/debian-lts-announce/2022/05/msg00027.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BVEO7BEFXPBVHSPYL3YKQWZI6DYXQLFS>
- <https://security.netapp.com/advisory/ntap-20220311-0005>
- <https://www.debian.org/security/2022/dsa-5196>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v7wg-cpwc-24m4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v7wg-cpwc-24m4/>. Everything for agents: <https://agentprime.io/llms.txt>.
