# Denial of Service via incomplete cleanup vulnerability in Apache Tomcat

Advisory record · `GHSA-v682-8vv8-vpwr`

- **Identifiers:** `GHSA-v682-8vv8-vpwr` · `BIT-tomcat-2024-23672` · `CVE-2024-23672`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-459](https://cwe.mitre.org/data/definitions/459.html)
- **Tags:** [CWE-459](https://agentprime.io/advisories/tag/cwe-459.md)
- **Published:** 13 Mar 2024
- **Updated:** 13 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Mar 2024, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.tomcat:tomcat-websocket` (Maven): affected `>=11.0.0-M1, <11.0.0-M17 || >=10.1.0-M1, <10.1.19 || >=9.0.0-M1, <9.0.86 || >=8.5.0, <8.5.99`; fixed in `11.0.0-M17`, `10.1.19`, `9.0.86`, `8.5.99`
- `org.apache.tomcat.embed:tomcat-embed-websocket` (Maven): affected `>=11.0.0-M1, <11.0.0-M17 || >=10.1.0-M1, <10.1.19 || >=9.0.0-M1, <9.0.86 || >=8.5.0, <8.5.99`; fixed in `11.0.0-M17`, `10.1.19`, `9.0.86`, `8.5.99`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat's tomcat-websocket and tomcat-embed-websocket packages are affected in versions from 11.0.0-M1 through 11.0.0-M16, 10.1.0-M1 through 10.1.18, 9.0.0-M1 through 9.0.85, and 8.5.0 through 8.5.98. A WebSocket client can keep connections open, increasing resource consumption and enabling denial of service. Upgrade to 11.0.0-M17, 10.1.19, 9.0.86, or 8.5.99. Older, end-of-life versions may also be affected.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.023, the 83rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-v682-8vv8-vpwr)

## Sources

- [GitHub Advisory Database: GHSA-v682-8vv8-vpwr](https://github.com/advisories/GHSA-v682-8vv8-vpwr)
- [OSV: GHSA-v682-8vv8-vpwr](https://osv.dev/vulnerability/GHSA-v682-8vv8-vpwr)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-23672>
- <https://github.com/apache/tomcat/commit/0052b374684b613b0c849899b325ebe334ac6501>
- <https://github.com/apache/tomcat/commit/3631adb1342d8bbd8598802a12b63ad02c37d591>
- <https://github.com/apache/tomcat/commit/52d6650e062d880704898d7d8c1b2b7a3efe8068>
- <https://github.com/apache/tomcat/commit/b0e3b1bd78de270d53e319d7cb79eb282aa53cb9>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/cmpswfx6tj4s7x0nxxosvfqs11lvdx2f>
- <https://lists.debian.org/debian-lts-announce/2024/04/msg00001.html>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B>
- <https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55>
- <https://security.netapp.com/advisory/ntap-20240402-0002>
- <http://www.openwall.com/lists/oss-security/2024/03/13/4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-v682-8vv8-vpwr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-v682-8vv8-vpwr/>. Everything for agents: <https://agentprime.io/llms.txt>.
